using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*donotbackup.*";
string input = @"donotbackup
test_donotbackup
donotbackup_test
test_donotbackup_test
TEST_DONOTBACKUP_TEST
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}