package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*donotbackup.*`)
var str = `donotbackup
test_donotbackup
donotbackup_test
test_donotbackup_test
TEST_DONOTBACKUP_TEST
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}