re = /^\{((?:(?:(?!\}).)+)(?:(?:\}\})?(?:(?:(?!\}).)+))+)\}(?!\})/m
str = '{class: name}
{ class : name }
{ \'class\' : \'name\' }
{ \'key\' : \'value\', \'key\': \'value\' }
{\'key\': \'value\'}
{\' key \': \' value \' , \'this\': \'guy\' }
{\' class \': \' in session \' , \'this\': \'guy\' } string
{\' class \': \' in session \' , \'this\': \'guy\' } string with {{ brackets }}
{\' class \': \'{{ parse me }}\' }
{\'key\': \'value\', checked: true}
{\'key\': \'value\', checked: {{ bool }} }
{\'asdf\': \'fda\', checked: {{ bool }}, strange: {{ bool }} } stuff {{ more }} #{interpolate}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end