$re = '/^\{((?:(?:(?!\}).)+)(?:(?:\}\})?(?:(?:(?!\}).)+))+)\}(?!\})/m';
$str = '{class: name}
{ class : name }
{ \'class\' : \'name\' }
{ \'key\' : \'value\', \'key\': \'value\' }
{\'key\': \'value\'}
{\' key \': \' value \' , \'this\': \'guy\' }
{\' class \': \' in session \' , \'this\': \'guy\' } string
{\' class \': \' in session \' , \'this\': \'guy\' } string with {{ brackets }}
{\' class \': \'{{ parse me }}\' }
{\'key\': \'value\', checked: true}
{\'key\': \'value\', checked: {{ bool }} }
{\'asdf\': \'fda\', checked: {{ bool }}, strange: {{ bool }} } stuff {{ more }} #{interpolate}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);