using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\{((?:(?:(?!\}).)+)(?:(?:\}\})?(?:(?:(?!\}).)+))+)\}(?!\})";
string input = @"{class: name}
{ class : name }
{ 'class' : 'name' }
{ 'key' : 'value', 'key': 'value' }
{'key': 'value'}
{' key ': ' value ' , 'this': 'guy' }
{' class ': ' in session ' , 'this': 'guy' } string
{' class ': ' in session ' , 'this': 'guy' } string with {{ brackets }}
{' class ': '{{ parse me }}' }
{'key': 'value', checked: true}
{'key': 'value', checked: {{ bool }} }
{'asdf': 'fda', checked: {{ bool }}, strange: {{ bool }} } stuff {{ more }} #{interpolate}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}