#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\{((?:(?:(?!\}).)+)(?:(?:\}\})?(?:(?:(?!\}).)+))+)\}(?!\})"
Local $sString = "{class: name}" & @CRLF & _
"" & @CRLF & _
"{ class : name }" & @CRLF & _
"" & @CRLF & _
"{ 'class' : 'name' }" & @CRLF & _
"" & @CRLF & _
"{ 'key' : 'value', 'key': 'value' }" & @CRLF & _
"" & @CRLF & _
"{'key': 'value'}" & @CRLF & _
"" & @CRLF & _
"{' key ': ' value ' , 'this': 'guy' }" & @CRLF & _
"" & @CRLF & _
"{' class ': ' in session ' , 'this': 'guy' } string" & @CRLF & _
"" & @CRLF & _
"{' class ': ' in session ' , 'this': 'guy' } string with {{ brackets }}" & @CRLF & _
"" & @CRLF & _
"{' class ': '{{ parse me }}' }" & @CRLF & _
"" & @CRLF & _
"{'key': 'value', checked: true}" & @CRLF & _
"" & @CRLF & _
"{'key': 'value', checked: {{ bool }} }" & @CRLF & _
"" & @CRLF & _
"{'asdf': 'fda', checked: {{ bool }}, strange: {{ bool }} } stuff {{ more }} #{interpolate}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")