const regex = /^\{((?:(?:(?!\}).)+)(?:(?:\}\})?(?:(?:(?!\}).)+))+)\}(?!\})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\{((?:(?:(?!\\}).)+)(?:(?:\\}\\})?(?:(?:(?!\\}).)+))+)\\}(?!\\})', 'gm')
const str = `{class: name}
{ class : name }
{ 'class' : 'name' }
{ 'key' : 'value', 'key': 'value' }
{'key': 'value'}
{' key ': ' value ' , 'this': 'guy' }
{' class ': ' in session ' , 'this': 'guy' } string
{' class ': ' in session ' , 'this': 'guy' } string with {{ brackets }}
{' class ': '{{ parse me }}' }
{'key': 'value', checked: true}
{'key': 'value', checked: {{ bool }} }
{'asdf': 'fda', checked: {{ bool }}, strange: {{ bool }} } stuff {{ more }} #{interpolate}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}