import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\{((?:(?:(?!\\}).)+)(?:(?:\\}\\})?(?:(?:(?!\\}).)+))+)\\}(?!\\})";
final String string = "{class: name}\n\n"
+ "{ class : name }\n\n"
+ "{ 'class' : 'name' }\n\n"
+ "{ 'key' : 'value', 'key': 'value' }\n\n"
+ "{'key': 'value'}\n\n"
+ "{' key ': ' value ' , 'this': 'guy' }\n\n"
+ "{' class ': ' in session ' , 'this': 'guy' } string\n\n"
+ "{' class ': ' in session ' , 'this': 'guy' } string with {{ brackets }}\n\n"
+ "{' class ': '{{ parse me }}' }\n\n"
+ "{'key': 'value', checked: true}\n\n"
+ "{'key': 'value', checked: {{ bool }} }\n\n"
+ "{'asdf': 'fda', checked: {{ bool }}, strange: {{ bool }} } stuff {{ more }} #{interpolate}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}