// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.|\s)*duplicates value on record with id(.|\s)*").unwrap();
let string = "com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot deserialize instance of `java.util.LinkedHashMap<java.lang.Object,java.lang.Object>` out of START_ARRAY token
at [Source: (String)\"[{\"message\":\"duplicate value found: EXT_ID_EFORCE__c duplicates value on record with id: 0030Y00000XPaP8\",\"errorCode\":\"DUPLICATE_VALUE\",\"fields\":[]}]\"; line: 1, column: 1]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}