using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.|\s)*duplicates value on record with id(.|\s)*";
string input = @"com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot deserialize instance of `java.util.LinkedHashMap<java.lang.Object,java.lang.Object>` out of START_ARRAY token
at [Source: (String)""[{""message"":""duplicate value found: EXT_ID_EFORCE__c duplicates value on record with id: 0030Y00000XPaP8"",""errorCode"":""DUPLICATE_VALUE"",""fields"":[]}]""; line: 1, column: 1]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}