import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.|\\s)*duplicates value on record with id(.|\\s)*";
final String string = "com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot deserialize instance of `java.util.LinkedHashMap<java.lang.Object,java.lang.Object>` out of START_ARRAY token\n"
+ " at [Source: (String)\"[{\"message\":\"duplicate value found: EXT_ID_EFORCE__c duplicates value on record with id: 0030Y00000XPaP8\",\"errorCode\":\"DUPLICATE_VALUE\",\"fields\":[]}]\"; line: 1, column: 1]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}