const regex = /(.|\s)*duplicates value on record with id(.|\s)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.|\\s)*duplicates value on record with id(.|\\s)*', 'gm')
const str = `com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot deserialize instance of \`java.util.LinkedHashMap<java.lang.Object,java.lang.Object>\` out of START_ARRAY token
at [Source: (String)"[{"message":"duplicate value found: EXT_ID_EFORCE__c duplicates value on record with id: 0030Y00000XPaP8","errorCode":"DUPLICATE_VALUE","fields":[]}]"; line: 1, column: 1]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}