re = /(.|\s)*duplicates value on record with id(.|\s)*/m
str = 'com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot deserialize instance of `java.util.LinkedHashMap<java.lang.Object,java.lang.Object>` out of START_ARRAY token
at [Source: (String)"[{"message":"duplicate value found: EXT_ID_EFORCE__c duplicates value on record with id: 0030Y00000XPaP8","errorCode":"DUPLICATE_VALUE","fields":[]}]"; line: 1, column: 1]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end