re = /^[a-zA-ZÀ-ÿ0-9 ()-]*$/m
str = 'a
ab
abc
abcdefghijklmn
abcdefghijklmnñopqrstuvwxyz
áéíóú
()
-
Aportaciones
Aportaciones
Aportaciones a
Aportaciones empleado 1 D-I (No Flex)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end