package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-ZÀ-ÿ0-9 ()-]*$`)
var str = `a
ab
abc
abcdefghijklmn
abcdefghijklmnñopqrstuvwxyz
áéíóú
()
-
Aportaciones
Aportaciones
Aportaciones a
Aportaciones empleado 1 D-I (No Flex)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}