import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-ZÀ-ÿ0-9 ()-]*$";
final String string = "a\n"
+ "ab\n"
+ "abc\n"
+ "abcdefghijklmn\n"
+ "abcdefghijklmnñopqrstuvwxyz\n"
+ "áéíóú\n"
+ "()\n"
+ "-\n"
+ "Aportaciones\n"
+ "Aportaciones \n"
+ "Aportaciones a\n"
+ "Aportaciones empleado 1 D-I (No Flex)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}