$re = '/^[a-zA-ZÀ-ÿ0-9 ()-]*$/m';
$str = 'a
ab
abc
abcdefghijklmn
abcdefghijklmnñopqrstuvwxyz
áéíóú
()
-
Aportaciones
Aportaciones
Aportaciones a
Aportaciones empleado 1 D-I (No Flex)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);