#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-ZÀ-ÿ0-9 ()-]*$"
Local $sString = "a" & @CRLF & _
"ab" & @CRLF & _
"abc" & @CRLF & _
"abcdefghijklmn" & @CRLF & _
"abcdefghijklmnñopqrstuvwxyz" & @CRLF & _
"áéíóú" & @CRLF & _
"()" & @CRLF & _
"-" & @CRLF & _
"Aportaciones" & @CRLF & _
"Aportaciones " & @CRLF & _
"Aportaciones a" & @CRLF & _
"Aportaciones empleado 1 D-I (No Flex)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")