using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-ZÀ-ÿ0-9 ()-]*$";
string input = @"a
ab
abc
abcdefghijklmn
abcdefghijklmnñopqrstuvwxyz
áéíóú
()
-
Aportaciones
Aportaciones
Aportaciones a
Aportaciones empleado 1 D-I (No Flex)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}