import Foundation
let pattern = #"([1|2]\d{3})\/((0[1-9])|(1[0-2]))\/([0-2][1-9]|(3[0-1]))T(([0-1]\d)|(2[0-3])):([0-5][0-9]):([0-5][0-9])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1900/01/01T05:59:00
2000/12/12T11:58:01
2000/12/12T12:48:59
2000/04/12T23:48:59
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)