#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([1|2]\d{3})\/((0[1-9])|(1[0-2]))\/([0-2][1-9]|(3[0-1]))T(([0-1]\d)|(2[0-3])):([0-5][0-9]):([0-5][0-9])"
Local $sString = "1900/01/01T05:59:00" & @CRLF & _
"2000/12/12T11:58:01" & @CRLF & _
"2000/12/12T12:48:59" & @CRLF & _
"2000/04/12T23:48:59" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")