use strict;
my $str = '1900/01/01T05:59:00
2000/12/12T11:58:01
2000/12/12T12:48:59
2000/04/12T23:48:59
';
my $regex = qr/([1|2]\d{3})\/((0[1-9])|(1[0-2]))\/([0-2][1-9]|(3[0-1]))T(([0-1]\d)|(2[0-3])):([0-5][0-9]):([0-5][0-9])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}