import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([1|2]\\d{3})\\/((0[1-9])|(1[0-2]))\\/([0-2][1-9]|(3[0-1]))T(([0-1]\\d)|(2[0-3])):([0-5][0-9]):([0-5][0-9])";
final String string = "1900/01/01T05:59:00\n"
+ "2000/12/12T11:58:01\n"
+ "2000/12/12T12:48:59\n"
+ "2000/04/12T23:48:59\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}