const regex = new RegExp('([1|2]\\d{3})\\/((0[1-9])|(1[0-2]))\\/([0-2][1-9]|(3[0-1]))T(([0-1]\\d)|(2[0-3])):([0-5][0-9]):([0-5][0-9])', 'g')
const str = `1900/01/01T05:59:00
2000/12/12T11:58:01
2000/12/12T12:48:59
2000/04/12T23:48:59
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}