re = /([1|2]\d{3})\/((0[1-9])|(1[0-2]))\/([0-2][1-9]|(3[0-1]))T(([0-1]\d)|(2[0-3])):([0-5][0-9]):([0-5][0-9])/
str = '1900/01/01T05:59:00
2000/12/12T11:58:01
2000/12/12T12:48:59
2000/04/12T23:48:59
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end