re = /^[a-z0-9]{6,}$/m
str = '123456
1234
abcdef
123abc
abc123
a1b2c3
2hfn32342
ck+p323245
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end