$re = '/^[a-z0-9]{6,}$/m';
$str = '123456
1234
abcdef
123abc
abc123
a1b2c3
2hfn32342
ck+p323245
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);