import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]{6,}$";
final String string = "123456\n"
+ "1234\n"
+ "abcdef\n"
+ "123abc\n"
+ "abc123\n"
+ "a1b2c3\n"
+ "2hfn32342\n"
+ "ck+p323245\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}