#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z0-9]{6,}$"
Local $sString = "123456" & @CRLF & _
"1234" & @CRLF & _
"abcdef" & @CRLF & _
"123abc" & @CRLF & _
"abc123" & @CRLF & _
"a1b2c3" & @CRLF & _
"2hfn32342" & @CRLF & _
"ck+p323245" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")