const regex = /^[a-z0-9]{6,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9]{6,}$', 'gm')
const str = `123456
1234
abcdef
123abc
abc123
a1b2c3
2hfn32342
ck+p323245
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}