package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9]{6,}$`)
var str = `123456
1234
abcdef
123abc
abc123
a1b2c3
2hfn32342
ck+p323245
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}