import Foundation
let pattern = #"(?<=https://www.facebook.com/groups/).*?(?=/)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"a href="https://www.facebook.com/groups/366139636814727/871873746241311/?comment_id=871905166238169&ref=notif¬if_t=group_comment" class="_33e" data-reactid=".3.0.0.0.0.0.$100000241272846=21446664199525942.0.0"><div class="clearfix" data-reactid=".3.0.0.0.0.0.$100000241272846=21446664199525942.0.0.0"><d"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)