using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=https://www.facebook.com/groups/).*?(?=/)";
string input = @"a href=""https://www.facebook.com/groups/366139636814727/871873746241311/?comment_id=871905166238169&ref=notif¬if_t=group_comment"" class=""_33e"" data-reactid="".3.0.0.0.0.0.$100000241272846=21446664199525942.0.0""><div class=""clearfix"" data-reactid="".3.0.0.0.0.0.$100000241272846=21446664199525942.0.0.0""><d";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}