#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=https://www.facebook.com/groups/).*?(?=/)"
Local $sString = "a href="https://www.facebook.com/groups/366139636814727/871873746241311/?comment_id=871905166238169&ref=notif¬if_t=group_comment" class="_33e" data-reactid=".3.0.0.0.0.0.$100000241272846=21446664199525942.0.0"><div class="clearfix" data-reactid=".3.0.0.0.0.0.$100000241272846=21446664199525942.0.0.0"><d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")