const regex = new RegExp('(?<=https://www.facebook.com/groups/).*?(?=/)', 'g')
const str = `a href="https://www.facebook.com/groups/366139636814727/871873746241311/?comment_id=871905166238169&ref=notif¬if_t=group_comment" class="_33e" data-reactid=".3.0.0.0.0.0.\$100000241272846=21446664199525942.0.0"><div class="clearfix" data-reactid=".3.0.0.0.0.0.\$100000241272846=21446664199525942.0.0.0"><d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}