import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=https://www.facebook.com/groups/).*?(?=/)";
final String string = "a href=\"https://www.facebook.com/groups/366139636814727/871873746241311/?comment_id=871905166238169&ref=notif¬if_t=group_comment\" class=\"_33e\" data-reactid=\".3.0.0.0.0.0.$100000241272846=21446664199525942.0.0\"><div class=\"clearfix\" data-reactid=\".3.0.0.0.0.0.$100000241272846=21446664199525942.0.0.0\"><d";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}