$re = '/(?<=https://www.facebook.com/groups/).*?(?=/)/';
$str = 'a href="https://www.facebook.com/groups/366139636814727/871873746241311/?comment_id=871905166238169&ref=notif¬if_t=group_comment" class="_33e" data-reactid=".3.0.0.0.0.0.$100000241272846=21446664199525942.0.0"><div class="clearfix" data-reactid=".3.0.0.0.0.0.$100000241272846=21446664199525942.0.0.0"><d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);