import Foundation
let pattern = #"[\w\-\.]+txt:route-policy\sGERENCIA_UBB_STATIC.+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGRJO-MTC01-01.txt- if tag eq 30210 then
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)