re = /[\w\-\.]+txt:route-policy\sGERENCIA_UBB_STATIC.+/
str = 'RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGRJO-MTC01-01.txt- if tag eq 30210 then
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end