// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\w\-\.]+txt:route-policy\sGERENCIA_UBB_STATIC.+").unwrap();
let string = "RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGRJO-MTC01-01.txt- if tag eq 30210 then
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}