const regex = new RegExp('[\\w\\-\\.]+txt:route-policy\\sGERENCIA_UBB_STATIC.+', 'g')
const str = `RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGRJO-MTC01-01.txt- if tag eq 30210 then
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}