import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w\\-\\.]+txt:route-policy\\sGERENCIA_UBB_STATIC.+";
final String string = "RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP\n"
+ "RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP\n"
+ "RMAGRJO-MTC01-01.txt- if tag eq 30210 then\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}