use strict;
my $str = 'RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGRJO-MTC01-01.txt- if tag eq 30210 then
';
my $regex = qr/[\w\-\.]+txt:route-policy\sGERENCIA_UBB_STATIC.+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}