re = /([Тт]ел[\p{L}|\.|\w|\s]*)<[^t][^r]*?>[\+|\s]?([\d|\s|\(|\)]{10,})/
str = '<td width="20%" style="padding-left:0%;"><b>Телефон домашний</b></td><td width="80%">+1 234 56 78 90</td></tr>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end