$re = '/([Тт]ел[\p{L}|\.|\w|\s]*)<[^t][^r]*?>[\+|\s]?([\d|\s|\(|\)]{10,})/';
$str = '<td width="20%" style="padding-left:0%;"><b>Телефон домашний</b></td><td width="80%">+1 234 56 78 90</td></tr>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);