use strict;
my $str = '<td width="20%" style="padding-left:0%;"><b>Телефон домашний</b></td><td width="80%">+1 234 56 78 90</td></tr>';
my $regex = qr/([Тт]ел[\p{L}|\.|\w|\s]*)<[^t][^r]*?>[\+|\s]?([\d|\s|\(|\)]{10,})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}