import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([Тт]ел[\\p{L}|\\.|\\w|\\s]*)<[^t][^r]*?>[\\+|\\s]?([\\d|\\s|\\(|\\)]{10,})";
final String string = "<td width=\"20%\" style=\"padding-left:0%;\"><b>Телефон домашний</b></td><td width=\"80%\">+1 234 56 78 90</td></tr>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}