using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([Тт]ел[\p{L}|\.|\w|\s]*)<[^t][^r]*?>[\+|\s]?([\d|\s|\(|\)]{10,})";
string input = @"<td width=""20%"" style=""padding-left:0%;""><b>Телефон домашний</b></td><td width=""80%"">+1 234 56 78 90</td></tr>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}