const regex = /([Тт]ел[\p{L}|\.|\w|\s]*)<[^t][^r]*?>[\+|\s]?([\d|\s|\(|\)]{10,})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([Тт]ел[\\p{L}|\\.|\\w|\\s]*)<[^t][^r]*?>[\\+|\\s]?([\\d|\\s|\\(|\\)]{10,})', '')
const str = `<td width="20%" style="padding-left:0%;"><b>Телефон домашний</b></td><td width="80%">+1 234 56 78 90</td></tr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}