// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<inl>\/\/[^\n]*\r?\n)|(?<mtl>\/\*[^\*]*\*\/)").unwrap();
let string = "codecode
//codecode
/*commmze */
/* comentaire
encore
et encore
*/
code cpode
/* com//mentaitree
/* imbrication
// méchant */
ça c'est du com à la con
*/
code code";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}